Vulnerabilities

Gutenberg Template Library & Redux Framework Bugs Plague WordPress Sites

Two vulnerabilities in the site-building plugin could be useful tools in the hands of a skilled attacker, researchers warned.

Two vulnerabilities have been found in the Gutenberg Template Library & Redux Framework plugin for WordPress, which is installed on more than 1 million websites. They could allow arbitrary plugin installation, post deletions and access to potentially sensitive information about a site’s configuration, researchers said.

The plugin, from developer Redux.io, offers various templates and building blocks for creating web pages within WordPress’ Gutenberg editor:

The Gutenberg Template Library & Redux Framework interface. Source: Redux.io.

The first bug (CVE-2021-38312) rates 7.1 out of 10 on the CVSS scale, making it high-severity. It arises from the plugin’s use of the WordPress REST API, which processes requests to install and manage the blocks. It fails to authorize user permissions correctly, according to Wordfence.

Infosec Insiders Newsletter

“While the REST API Endpoints registered under the redux/v1/templates/ REST Route used a permission_callback to verify a user’s permissions, this callback only checked whether or not the user sending the request had the edit_posts capability,” Wordfence researchers noted in a Wednesday posting.

That means that users with lower permissions, such as contributors and authors, could install any plugin in the WordPress repository via the redux/v1/templates/plugin-install endpoint, researchers said, or they could use the redux/v1/templates/delete_saved_block endpoint to erase posts.

The second, medium-severity vulnerability (CVE-2021-38314) rates 5.3 on the CVSS scale. It exists because the Gutenberg Template Library & Redux Framework plugin registers several AJAX actions available to unauthenticated users, one of which is deterministic and predictable, making it possible to uncover what the $support_hash for a site would be.

“This $support_hash AJAX action, which was also available to unauthenticated users, called the support_args function in redux-core/inc/classes/class-redux-helpers.php, which returned potentially sensitive information such as the PHP version, active plugins on the site and their versions, and an unsalted md5 hash of the site’s AUTH_KEY and SECURE_AUTH_KEY,” according to Wordfence.

Researchers added that an attacker could use the information to plan a website takeover using other vulnerable plugins.

Redux.io has issued a patch, in version 4.2.13.

Wordfence researchers said users should update their plugins as soon as possible: “While neither of these could be used directly to take over a site, both vulnerabilities could be useful tools in the hands of a skilled attacker,” they said.

WordPress Plugin Problems Persist

These are only the latest WordPress plugin vulnerabilities to come to light. Other notable vulnerabilities this year include:

  • January: Researchers warned of two vulnerabilities (one critical) in a WordPress plugin called Orbit Fox that could allow attackers to inject malicious code into vulnerable websites and/or take control of a website.
  • January: A plugin called PopUp Builder, used by WordPress websites for building pop-up ads for newsletter subscriptions, was found to have a vulnerability that could be exploited by attackers to send out newsletters with custom content, or to delete or import newsletter subscribers.
  • February: An unpatched, stored cross-site scripting (XSS) security bug was found to potentially affect 50,000 Contact Form 7 Style plugin users.
  • March: The Plus Addons for Elementor plugin for WordPress was discovered to contain a critical security vulnerability that attackers can exploit to quickly, easily and remotely take over a website. First reported as a zero-day bug, researchers said that it was being actively attacked in the wild.
  • May: An SQL-injection vulnerability discovered in a WordPress plugin called “Spam protection, AntiSpam, FireWall by CleanTalk.” It could expose user emails, passwords, credit-card data and other sensitive information to an unauthenticated attacker.
  • July: A critical cross-site scripting (XSS) bug that affects WordPress sites running the Frontend File Manager plugin was found. It allows remote unauthenticated users to inject JavaScript code into vulnerable websites to create admin user accounts.

Check out our free upcoming live and on-demand webinar events – unique, dynamic discussions with cybersecurity experts and the SACUT community.

Back to top button